Support

Your browser

You’ll need a browser that supports MathML and Flash. Right now, you can choose between Mozilla Firefox and Internet Explorer.

Mozilla Firefox

Just install Mozilla Firefox and you’re ready to use Dr.Stat. Firefox has excellent support for MathML en will help you install the Flash player when needed.

Internet Explorer

If you need or want to use Internet Explorer, you’ll have to install MathPlayer. If you don’t have Flash installed, please download the Flash Player from Adobe.

Technical trouble?

Send a short, but clear description of the issue by email to support@drstat.net and we’ll try to help you as soon as possible. Don’t forget to include your email address.

Don’t understand the lessons?

I’m afraid we can’t help you with questions about the lessons at this time.



Designed & developed by Fingertips